…mit Windows XP umziehen

Es könnte alles so einfach sein.
geschrieben von
Sebastian

Neulich stand ich vor dem Problem, mit einem Windows-XP System auf einen neuen Rechner umzuziehen. Laut Microsoft ist es nicht möglich ein System in einen komplett anderen Rechner zu stecken. Da aber ziemlich alte Programme darauf laufen und es keine Quellen mehr dafür gibt, musste eine Lösung her.Also alte Systemplatte ausgebaut und in den neuen Rechner gesteckt.

Spannung… Fährt hoch…Windows XP-Logo… Bluescreen und tschüss. Shit!

Folgender BSoD begrüßte mich: STOP: 0x0000007E (0xC0000005, 0xB82A8756, 0xB84C342C, 0xB84C3128)

Kam aber irgendwie nicht unerwartet. Das System ließ sich zum Glück im abgesicherten Modus starten und zumindest dieser Fehler beheben. Wie genau? Das will ich kurz erklären. Wenn man von einer Intel-CPU auf eine AMD-CPU wechselt und dann noch ein OEM-System hat, muss man zwingend einen Eintrag in der Registry ändern.

Nämlich folgenden: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Intelppm
windows-xp-registry-intelppm

Hier ändern wir den Wert des Eintrags „Start“ von 1 auf 4.

Speichern und Neustart. Das System sollte nun „normal“ starten.

Wer jetzt auf der sicheren Seite sein will der löscht noch alle Treiber aus dem Gerätemanager. Und weil das händisch einfach ewig dauert, machen wir uns ein Windowstool zunutze. Mit diesem lassen sich alle Treiber in einem Rutsch löschen. Diese werden dann automatisch bei einem Neustart installiert.

Dafür gehen wie folgt vor: Wie laden uns von der Microsoftwebsite das Programm Devcon.exe runter. Ich habs dann einfach nach „C:\Windows\inf“ gepackt. Find ich einfacher…

Dann öffnen wir die Kommandozeile mit „Start/Ausführen/cmd“ und wechseln mit „cd /D C:\Windows\inf“  in das Verzeichnis.

Jetzt sammeln wir die Treiber in einer Liste: devcon findall * > treiber.txt 

Und mit for /F „tokens=1,2 delims=:“ %i in (treiber.txt) do @for /F „tokens=1,2 delims= “ %a in („%i“) do devcon remove „@%a“ werden diese komplett gelöscht. Das kann eine ganze Weile dauern… Also macht euch erstmal einen Kaffee 😉

Wenn Devcon dann fertig ist kommt noch ein devcon rescan von uns hinterher und wenn alles okay ist, können wir auch gleich neustarten. Der Neustart kann auch wieder eine ganze Weile dauern, da ja alle Treiber neu installiert werden. Treiber die nicht standardmäßig in Windows vorhanden sind, müssen ggf. von CD oder von der Herstellerseite bezogen werden.

Bei mir lief nach dieser Prozedur, die übrigens mit Ein- und Ausbau und der Suche nach einer Lösung, mehr als sieben Stunden dauerte, wieder alles reibungslos. :)

Quellen: Acronis-Forum , Hardwareluxx

 

Article Categories:
Computer · Windows XP
  • Title:…mit Windows XP umziehen
  • Created:August 27, 2013
  • Updated:Mon, 29 Jun 2015 22:31:02 +0000
  • Author:Sebastian Kinsky

Kommentare

  • Gott – DANKE
    Suche schon seit Stunde nach dem Fehler, dachte immer ein Treiber den ich noch nicht vollständig entfernt habe ist das Problem. Nach deinem Registry-Eintrag fährt er aber auch wieder normal hoch. Vielen Dank!

    Doom 16. Dezember 2015 22:27 Antworten

Leave a Comment

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind markiert *

Navigation